rianto isaac's Weblog

rianto utomo isaac sahala utomo

linux, mikrotik 2 ISP

leave a comment »

Mikrotik Dengan 2 ISP ( non fail over )

Kasus ini terjadi di kantor saya dimana didalam LAN terdapat berbagai macam client, antara lain Internal ( staff perusahaan ) dan Management ( kelompok managemen ).

Walaupun berada dalam satu jaringan fisik, namun mereka berada pada sub net yang berbeda :

Internal = 192.168.0.0/24

Management = 192.168.1.0/24

Sekarang timbul permasalahan saat pihak management meminta akses Internet dari ISP yang berbeda dengan kapasitas yang berbeda pula. Sebelumnya adalah menggunakan satu ISP saja. Penggabungan Dua ISP ini tidak menggunakan metode FAIL OVER.

Akhirnya saya putuskan untuk memasang tambahan 1 LAN Card pada router menjadi 3 LAN Card dari sebelumnya hanya 2 LAN Card saja :

eth1 = xx.xx.xx.xx/xx ( ISP 1 )

eth2 = 192.168.0.0/24 ( LAN Internel )

eth2 = 192.168.1.0/24 ( LAN Management )

eth3 = yy.yy.yy.yy/yy ( ISP 2 )

keterangan.

eth2 di set duplicate IP untuk menggabung jaringan LAN pada jaringan fisik yang sama.

Setting Dua ISP pada mikrotik saya temukan pada blog Jauh Dimata dengan sedikit modifikasi penyesuaian. Source asli dapat dilihat di sini.

Berikut langkah – langkah setting :

1. Set IP pada eth1 ( ISP 1 )

/ip address add address=xx.xx.xx.xx/xx interface=eth1

2. Set IP pada eth2 ( LAN Internal )

/ip address add address=192.168.0.1/24 interface=eth2

3. Set IP pada eth2 ( LAN Management )

/ip address add address=192.168.1.1/24 interface=eth2

4. Set IP pada eth3 ( ISP 2 )

/ip address add address=yy.yy.yy.yy/yy interface=eth3

5. Setting Gateway Utama ( gateway dari ISP 1 )

/ip route add gateway=xxx.xxx.xxx.xxx/xx routing-mark=LB-RM check-gateway=ping

6. Setting Gateway Kedua ( gateway dari ISP 2 )

/ip route add gateway=yyy.yyy.yyy.yyy/yy

7. Memberi tanda pada routing dari LAN Internal ( 192.168.0.0/24 ) agar menggunakan Gateway Utama

/ip firewall mangle add chain=prerouting src-address=192.168.0.0/24 action=mark-routing new-routing-mark=LB-RM

8. Setting Masquerade pada eth2 untuk jaringan LAN Internal agar jalur Internet via ISP 1 di eth1

/ip firewall nat add chain=srcnat out-interface=ether1 src-address=192.168.0.0/24 action=masquerade

9. Setting Masquerade pada eth2 untuk jaringan LAN Management agar jalur Internet via ISP 2 di eth3

chain=srcnat out-interface=ether3 src-address=192.168.1.0/24 action=masquerade

Saat saya coba teknik ini, internet berjalan normal di kedua subnet, begitu juga dengan check ip public yang berjalan pada masing – masing sub net saat akses internet sudah sesuai.

IP ISP 1 = xx.xx.xx.xx pada subnet LAN Internal

IP ISP 2 = yy.yy.yy.yy pada subnet LAN Management

Untuk mengetahui IP Public yang kita gunakan saat melakukan akses pada Internet seperti uji coba diatas, anda dapat menggunakan Tool What My IP Is

rianto utomo bole nyontek dari http://komunitaskami.com/komunitas-networking/mikrotik-how-to-mikrotik-dengan-2-isp-non-fail-over/

Written by isaaconi

Februari 3, 2009 pada 4:12 am

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: